
 

NEW CEIBO DEBUGGER

Menus and Commands



Windows Menus and Commands D-1

Ceibo Debugger Menus and
Commands

D.1. Introduction

CEIBO DEBUGGER is the latest software available from Ceibo and can be used
with most of Ceibo emulators. You will find a detailed description of the menus
and their related commands in the following paragraphs. As the debugger is
general for all the 8051 derivatives, some specific functions may not apply to
all the derivatives.

D.2. Global and Local Menus

 • A Global Menu is the list of commands easily accessible from a bar which
runs along the top of the window. A pull-down menu is available for each
item on the menu bar and allows executing a command, opening a pop-up
menu and checking an option to select it. Global menus are accessed by using
the mouse to click the option, pressing F10 and arrow keys or pressing Alt
and typing the underlined letter of the menu name.

 • Ceibo Debugger is context-sensitive and uses Local Menus specifying
different windows. Local menus are tailored to the particular window you are
in. To prompt a local menu press Alt-F10 or click the right button of your
mouse. Menu placement and contents depends on which window or pane you
are in and where your cursor is.

D.3. Toolbars

The buttons on the Toolbar are the commands you need to operate the most
useful functions:

FIGURE D.1: Debug bar
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Debug bar buttons from left to right: Go, Break, Restart, Toggle Breakpoint,
Origin, Trace Into, Step Over, Step Out, Go to Cursor, Output, Watch, Variables,
Modules and Registers, Memory, Stack and CPU.

FIGURE D.2: Windows bar

Windows bar buttons from left to right: New Windows, Split, Cascade Windows,
Tile Horizontal and Tile Vertical.

FIGURE D.3: Edit bar

Edit bar buttons from left to right: Cut, Copy and Paste.

FIGURE D.4: Main Bar

Main bar buttons from left to right: Open File, Find File, About and Help

D.4. Status Line

The status line on the bottom of the main application window displays messages
related to the cursor position in the Module window, chip type, operating mode
(simulation or emulation) and current status (program running, ready, error). It
also provides on-line help information on selected menus.

Important: if SIM appears on that bar, the system is in SIMULATION MODE
and your code will not run in real time. Select EMULATION MODE in the
Options Menu and connect your Ceibo Emulator to your computer.

FIGURE D.5: Status Bar

D.5. File Menu

The File menu options deal with operations external to the Ceibo Debugger, such
as loading programs for debugging, and leaving the application. The available
commands are: Load, Close, Unload, Print, Print Preview and Exit. This menu
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also provides a list of the last opened files, so you may load a file just by clicking
on the desired file name.

FIGURE D.6: File Menu

Load

The Load command loads a program for debugging from a disk. You may select
the directory and the file name to be loaded, as well as the format of the file to
achieve complete debug information compatibility.

The supported file formats are: Intel Hex, OMF51, Keil, IAR-UBROF, Tasking-
IEEE695 and many others.

Utility programs and software updates may be released in the future to support
new compilers with different formats.

From the File Menu you can specify the Symbol Only option, thus loading only
the symbol information in the file for debugging ROM applications. Code is not
loaded in this case.

The Startup Skip option is used to run the program automatically until the first
line of your main program is reached.

If selected, the program will run from 0000h to the Main label while debugging C.
Uncheck the Skip Startup Code box if you want to start debugging from
address 0000h.
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FIGURE D.7: File Open Dialog

Select the software vendor before loading a file. Use the File of Type list to
make your selection.

FIGURE D.8: Files of Type

Close

The Close command closes the loaded file.

Unload

This command deletes all the symbol information loaded by the Load Command,
thus clearing symbols and code.
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Print

This command prints the loaded file. You may preview the file and also define
the print setup.

Exit

The Exit command terminates the debugging session. The hot key Alt-F4 can also
be used to leave the debugger. The Windows Alt-Tab key sequence may also be
used to leave temporarily the session without closing it.

D.6. Edit Menu

The Edit menu commands are standard for editing, finding and replacing text y
the loaded file. The available commands are Cut, Copy, Paste, Find, Find in Files
and Replace.

FIGURE D.9: Edit Menu

From the Find Dialog you may specify what to find and the direction in the text,
as well as other text attributes.

FIGURE D.10: Find Dialog

You may also specify in which files to find a string from the Find in Files Dialog.
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FIGURE D.11: Find in Files Dialog

D.7. View Menu

The View menu commands open windows that display different aspects of the
program being debugged.

You may open as many windows as you need. The following figure shows an
example.

FIGURE D.12: Opening Multiple Windows

The available commands are: Debug Space, Status Bar, Output, Toolbars,
Breakpoints, Memory Windows, Debug Windows, Target and Trace.
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FIGURE D.13: View Menu

Debug Space

From this window you may select the module of the loaded project to set
breakpoints, watch variables, source level debugging and more. By using the local
menu you may find a file or open all the modules. You may also select one
module from the list just by clicking on its name.

FIGURE D.14: Debug Space - Modules

From the Module window you can use the local menu add a variable to the
Watch window, define the program counter (New pc) or go to the certain line.
The Origin command refreshes the screen to the current position of the program
counter. Set directly a breakpoint by moving the cursor to the desired line and
pressing F2. Furthermore, you can drag a variable to the Watch window.
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FIGURE D.15: Debug Space - Modules

The Registers page shows the CPU main registers and the local menu can be used
to modify them.

FIGURE D.16: Debug Space - Registers
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Status Bar

This command is used to turn on or off the status bar. It is used to arrange
windows according to your preferences.

Output

FIGURE D.17: View Output

Use this window to log and display debug activities. This is useful to review the
sequence of the debug session.

Toolbars

This command is used to turn on or off the main, debug, edit and windows bar. It
is used to arrange windows according to your preferences.

Breakpoints

The Breakpoints menu commands let breakpoints be displayed, set and cleared.
The different options may be accessed through the Local menu of this window
and they are used to add, delete, enable or disable breakpoints.

FIGURE D.18: Breakpoints Local Menu

Memory Windows

The Memory windows show the specified areas of memory. Data can be viewed
as raw hex bytes with  their corresponding ASCII representation. You may open
a page showing internal data memory (Data), code memory (Code) and external
data accessed by MOVX instructions (Xdata). Click on a value to modify it.
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FIGURE D.19: Memory Windows

Debug Windows

The Debug windows show information related the debug session: variables in
your code, watch windows with your defined variables to be displayed, Stack
values and CPU window with the assembly code.

Variables

The Variables command opens a Variables window displaying a list of the
program global (or public) and local symbols, and their locations.

FIGURE D.20: Variables Window

Click on a variable to change the value.

FIGURE D.21: Changing Variable Values
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Watches

The Watches command shows the value of specified variables. You may drag a
variable from the module window or type in the name of the variable.

FIGURE D.22: Variable Local Menu

These Local menu is used to add a watch, edit and delete.

You may enter any predefined symbol like P1, P1.0, R3, etc. or make an
absolute reference using the first letter to define the variable type followed by a
colon and the address.  Furthermore, absolute references may be expressed with
a length.

The syntax is:

                                      absolute_reference:address,length

Absolute references are D for the on-chip RAM, X for XRAM, P for ports and
any SFR (special function registers), C for code memory and B for bit memory.
Some examples are:

D:100,5

B:0x80,5

X:0x1000,8

P:0x431

Addresses are entered using the syntax of the selected language in the Options
menu, Environment, Interface.  Length is always decimal.

Your entries use the syntax of the selected language in the Options menu.  For
example, if you select C and you want to enter 9Fh, just type 0x9F.  The 9FH
entry is recognized if the selected language is ASM. In case that you are using
Pascal, enter $9F.

A string may be changed by entering values separated by commas or blank
spaces.
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Stack

The Stack window shows the stack bytes with the associated addresses relative to
the stack pointer.  For example, the address -2 means stack pointer contents
minus 2.

FIGURE D.23: Stack

CPU

The CPU command opens a CPU window displaying the disassembled
instructions of your program. An instruction may be displayed with symbol
information, and mixed with source code lines. You may also patch-up code
using the built-in assembler.

FIGURE D.24: CPU

The Local menu enables the following commands: Add Watch, Origin that
refreshes the screen to the current position of the program counter, Go to a
specified address, New PC setting the program counter to the current position of
the cursor, Mixed to display lines with source information, Toggle Source to
toggle between disassembled code and code embedded with source line numbers,
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Assemble to on-line modify your code and finally, Print to File saving any
portion of your code in ASCII format to a disk file.

Target

This command opens different windows that are related to the target
microcontroller emulated or simulated by the debugger.

FIGURE D.25: Target Menu

The available windows that may be opened depend on the microcontroller and
they may be Port, Interrupt, Serial and many others.

From any of there windows you may click on a variable to change its value.

Trace

The Trace menu allows the current Trace window to be opened, as well as
viewing the trace status.  Trace functions are enabled in both emulation and
simulation modes.

The Trace window allows the current trace buffer to be viewed, display different
formats for the trace selected, filter data from the trace display and search data
patterns in the buffer. Go to sets the cursor to the specified frame number.

Origin displays the window starting from the first recorded frame. Inspect shows
additional information about the variables recorded in the trace buffer.

Display Mode selects source code, disassembled instruction or mixed source and
disassembled code.

Time Stamps is used to display the absolute cycles (accumulated number of
cycles), absolute time (accumulated time according to the XTAL selection in the
Options menu) and relative cycles (number of cycles of  each frame).
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Clear Trace deletes all the accumulated data. Print to File saves the trace buffer
in a disk file.

FIGURE D.26: Trace Menu

D.8. Run Menu

The Run menu commands execute the program being debugged. The following
options are available: Run, Execute Forever, Go to Cursor, Trace Into, Execute
to, Step Over, Animate, Instruction Trace, Continuous Run, Halt and Program
Reset.

FIGURE D.27: Run Menu
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Go

The Go command executes the program continuously until either the program is
halted with the Halt key, or a breakpoint is reached. The F9 key is the hot key
that executes this command.

Go to Cursor

The Go to Cursor command executes the program until the instruction or source
line pointed by the cursor is reached. The current window must be a CPU
window or a Module window in order to determine which location to execute.

Trace Into

The Trace Into command executes a high-level language source line or a single
machine instruction. If your code module does not include debug information, the
Trace into command executes a single machine instruction that may be observed
in the CPU window. In case you have a code module with debug information, this
command executes a complete line step. The F7 key is the hot key that executes
this command.

Step Over

The Step over command executes a high-level language source line or a single
machine instruction. If your code module does not include debug information, the
Step over command executes a single machine instruction that may be observed
in the CPU window. The only exception occurs when your code has a CALL
instruction; then the program execution continues until it returns to the line
following the CALL instruction. If the program does not return to the next line it
will keep running. The F8 key is the hot key that executes this command.

Step Out

The Step out command executes a high-level language source lines until the end
of a function.

Presentation

This command steps automatically though the program.

Restart

The Restart command issues a hardware reset to the emulated Microcontroller,
causing all registers and on chip peripherals to return to their reset state. If you
loaded a program with the Startup Skip option, the program will execute the
startup code as well. Ctrl-F2 is the hot key for this command.
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Break

The Break command stops the currently running program. Ctrl-Break is the hot
key for this command.

D.9. Breakpoints Menu

The Breakpoints menu commands let breakpoints be set and cleared.

The following commands are available: Toggle and Delete All.

FIGURE D.28: Breakpoints Menu

Toggle

The Toggle command sets or clears a breakpoint at whatever address the cursor is
pointing to in the CPU window or in the Module window. The program will stop
each time it reaches a line where a breakpoint has been set, or a global or
hardware breakpoint occurs. The F2 key is the hot key that executes this
command.

At..

The At command executes the program and stops the program at a specific
location. The address can be entered in any of the valid address formats.

FIGURE D.29: Breakpoint At..
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Delete All

The Delete All command deletes all the breakpoints from the program. This
includes software, hardware, or expression true global breakpoints. This
command is used when debugging is to be continued without stopping the
program at any previously set breakpoint location.

D.10. Options Menu

The Options menu allows adjustment of some options that have a global effect on
the conduct of the Windows Debugger, and the remote emulator system.

The following are the available options: Environment, Module List File, Mode,
Communication, Chip, Architecture, Debug Controls, Save Options and  Restore
Default.

FIGURE D.30: Options Menu

Environment

The Environment option allows you to control the general environment
parameters of Windows Debugger. The following options are available: Path,
Format and Interface.

FIGURE D.31: Options Menu - Environment   - Path
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The Path for Source List option defines the directory trees in which the  debugger
will search for the source list files of your program.

The Format option is used to set your preferred font and color for each window.

FIGURE D.32: Options Menu - Environment Format

The Interface option selects the source language for your value entries and
several display options.

FIGURE D.33: Options Menu - Environment Interface

The Language command determines the base and syntax of your entries.  For
example, if you choose C Language, 55 is a decimal value and 0x55 is a
hexadecimal number.  In case the Assembler is selected, you should type 55h to
enter the same hexadecimal value.
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The Integer Display Format command defines the base of the display in the
Watches Window.  You can select hexadecimal, decimal or both bases for
displaying your variables.

Module List File

The Module List File option is used to set the list file name associated with each
module of the program being debugged.

The Module command will only allow access to modules with valid list files
found in your disk.

Use the File Find button to redefine the list file names and paths. First click on a
module name to select it. Then, use the File Find button to open the Module List
Files Dialog Box.

Whenever loading an ASM program for the first time, the default setting will be
the module_name.LST. It is therefore recommended to keep the module name
equal to the list file name, as it will prevent you from having to configure this
setting. Otherwise you will need to assign the list file name for each module after
loading a new program to debug for the first time.

FIGURE D.34: Module List Dialog Box

Mode

The Mode option allows you to select the operation mode of Windows Debugger.
The following options are available: Emulation and Simulation.

Emulation: The Emulation Mode option sets the Debugger to operate in full
emulation mode. In this mode your program will be executed in real time on the
remote emulator system. This mode requires the use of a Ceibo Emulator
connected to your PC. Communication error will result if the emulator is not
found on the selected COM port.
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Simulation: The Simulation Mode option sets the Windows Debugger to operate
in full simulation mode. In this mode, your program instruction execution will be
simulated by the debugger built-in simulator. This mode can be operated without
connecting any remote emulator system, thus allowing software debugging to be
done while the emulator is used for hardware debugging, or other projects. This is
not a real-time mode; only basic functions are supported and not all SFRs
belonging to particular derivatives. Set the system to emulation mode, while
using the debugger with a Ceibo Emulator.

FIGURE D.35: Options Menu - Mode

Communication

The Communication option allows selection of the host PC COM port number to
be used for communication with the remote emulator system.

Make sure that there are no resident programs hooked up to the selected COM
port, when being used for remote emulation interface.

FIGURE D.36: Options Menu - Communication

Chip
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The Chip option is used to tell the debugger which microcontroller is being used
by the emulator or simulator. It defines SFRs and other parameters accordingly.

FIGURE D.37: Options Menu - Chip

Architecture

This command defines specific emulator options in case which are required by
the hardware configuration, as the same debugger supports many microcontroller
derivatives with different hardware emulators. The available options are Data
Map, Xtal and Halt Mechanism.

Data Map specifies the memory accessed by MOVX instructions. It can belong to
the on-chip memory or to the target board.

FIGURE D.38: Architecture - Data Map

Xtal sets the clock frequency applied to the microcontroller. A programmable
clock generator is implemented in the emulator to support this feature.



D-22 CEIBO DEBUGGER User's Manual

FIGURE D.39: Architecture - XTal

Halt Mechanism sets the options to stop the emulation while it cannot be done by
a breakpoint. More details about this important setup are given in the Emulator
User Manual.

FIGURE D.40: Architecture - Halt Mechanism

Debug Controls

Debug Controls dialog is used to define the following:

Reload Setting: you may define whether the last loaded code will be
automatically reloaded or not. Automatic reloading is possible while powering up
the system or when a program reset is executed.

Origin Enable: this option specifies where the cursor will point to while stopping
the emulation. If the box is checked, that enables the origin and the cursor will
point to the actual program counter value in the CPU and Module windows. If it
is not checked, those windows will remain in the same state as they have been
while running the program.
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FIGURE D.41: Debug Controls

Save Options

Select this command if you want to save the setup while leaving the debugger.
This setup will be restored while invoking again the debugger. It saves window
layouts at any time and with any filename.

Restore Defaults

The Restore Defaults command allows you to load a configuration file from disk.
The configuration file should have been previously saved by using the Save
Options command.

D.11. Windows Menu

The Window menu allows various operations on the currently open windows with
the following commands: New, Tile, Cascade and Arrange Icons.

FIGURE D.42: Windows Menu

D.12. Help Menu
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The Help menu commands open a help window for whichever subject will be
selected from the menu. This menu offers the following options: Help Topics and
About.

FIGURE D.43: Help Menu

Not all the help contexts are listed, only the useful subjects and starting points.
Shift-F1 is the hot key that executes this command.

The About command displays the debugger software version.




